Ссылка на страничку GPSDump - программы для загрузки/выгрузки контрольных точек (старт, финиш, ППМ) в/из различных навигационных приборов, а также для выгрузки содержимого треклогов.
Ссылка на страничку FS - программа для оценки выступления участников соревнований. Среди прочих формул оценки, в ней присутствует и формула GAP (на сегодня - GAP2008).
Примечание: для работы этой программы (FS) необходимо иметь установленной среду Microsoft .NET Framework Version 2.0 (ссылка может не работать, но гугль решает почти всё).
Итак, программы выкачаны и распакованы, а пакет .NET установлен в системе.

По обведенным красным цветом участкам видно, что всё необходимое расположено в каталоге (папке, если угодно) "fs" на диске "D:". А интересующие нас программы скрываются за личиной файлов FSComp.exe (учёт и оценка выступления спортсменов) и GpsDump448.exe (средство для работы с приборами GPS).


Далее следует пошаговая инструкция, как "обрабатывать" приборы GPS участников соревнований с минимальными зартатами времени во время проведения собственно... самих соревнований.

Шаг 1.
Запускаем программу FSComp.exe. Компьютер, немного "подумав", отобразит программу на экране в виде окна следующего вида.
Окно как окно. Ничего примечательного. Но, если оно не появится, то "ройте" в сторону установки Microsoft .NET Framework Version 2.0. Может быть, понадобиться запустить инсталлятор этого пакета заново.
Впрочем, пугать не буду: обычно, с этим пакетом проблем не бывает.
Идём далее...


Шаг 2.
Создаём "новые соревнования". Для этого, в меню "Файл" выбираем пункт "Новые соревнования".
Как видно из меню, кроме пункта "Новые соревнования", нам доступны пункты "Открыть соревнования" и "Копировать соревнования".
Думаю, что нет нужды объяснять смысл этих пунктов меню.


Шаг 3.
Заполним нужные поля и выберем формулу подсчёта очков.
Ну, понятно, что правильное название соревнований... "как лодку назовёшь...".
Мне почему-то кажется, что если соревнования заявлены в ФАИ под kakim-to nazvaniem, то именно это nazvanie и нужно прописать в поле "Name".
"Location" - где проводятся соренования (Украина, Україна, Ukraine или что-нибудь иное - вам решать; главное, чтобы ваши тексты были понятны чиновникам ФАИ, если соревнования заявлены в календаре этой организации).
"Offset..." - часовой пояс. Летнее время в Украине имеет смещение в +3 часа относительно UTC. Не "угадаете" с часовым поясом - программа вас озадачит неожиданными решениями!
Кнопка "Set Scoring formula" - выбор формулы и настройка её параметров. Но, не будем углубляться в дебри формул - не для того это "способие" было задумано.


Шаг 4.
В итоге, приходим к такому вот виду - программа ждёт от нас действий по вводу информации об участниках соревнований:
Двойной щелчок "левой мышкой" - рулит!

В появившемся окне вводим имя и/или фамилию, а можно и часть того или другого:

Если ваш компьютер подключен к интернету, то получить имена участников, числящихся в базе ФАИ - проще паренной репы.
Нажимаем на кнопку "Search CIVL db" и...

...программа, порывшись в базе ФАИ, предложит один или несколько вариантов, подходящих под ваш запрос.
Вот так выглядит окошко с результатами поиска:
Двойным щелчком мыши (по нужной строке) завершаете нелёгкое дело заполнения формы.
Да! Обращаю ваше внимание на тот нехороший факт, что имя пилота идёт первым, а фамилия - вторым местом. Это - очень неудобно, но так принято (почему-то?) в ФАИ.
Если, вы не планируете отправлять результаты соревнований в ФАИ, то можете записывать имена/фамилии пилотов кириллицей. Равно, как и названия команд и т.д.
Естественно, при этом фамилию можно ставить первой.

С этой картинкой сильно вдаваться в подробности не буду - и так всё почти понятно.
Скажу только, что в поле "Custom pilot attributes" можно вписать новый атрибут - "Team" или "Komanda" ("команда", то есть), а в колонке под названием "Value" ("значение", по нашему) - указать название команды (раз уж о ней разговор зашёл).
В дальнейшем название команды можно выбирать из готового списка. Ну, чтобы не писать одно и то же по три-четыре раза.
Атрибут "Team"/"Komanda" пригодится при составлении отчётов (итоговых таблиц). Не ранее.
Кстати, команды можно создавать и "гораздо после". Не обязательно это делать при составлении списка участников.

В итоге? мы получим вот такой вот список участников соревнований.


Шаг 5.
Сохраним все данные в виде файла базы данных FSDB.
Меню "Файл", пункт "Сохранить как..."
Красненьким обведено предупреждение, что "новое соренование, всё ещё не сохранено".
Придумываем файлу имя попроще и запоминаем, где этот файл будет сохранён.

Шаг 6.
Закрываем программу FS и запускаем - GPSDump.
В меню "Misc." вызываем пункт "Competition Mode".

Появляется ма-а-а-аленькое такое окошечко с красноречивым названием "Competition Mode".
Перво-наперво, включаем "птичку" у "Competition mode enabled", что в переводе на великий и могучий означает не что иное как "соревновательский режим включЁн".
Затем, будет полезно указать дату и время начала соревнований, равно - как и конца. Это - на случай, чтоб "шальные треки" (с датами/временем, не попадающими в этот диапазон) не принимались в рассмотрение.

Наконец, давим на кнопку "Read pilot list" и на свет бо... на экране появляется стандартное диалоговое окно выбора файла. Да! Именно так это окно и называется. Ну, а в заголовке этого стандартного диалогового окна прописано, для чего оно выскочило: "Read pilot list file" - прочитать файл со списком пилотов. Я намеренно отодвинул это окошко чуть вниз, чтобы стало видно окно "Competition Mode"... ну-у-у-у, чтоб не забывали "зачем мы сюда зашли".
Прошу также обратить внимание на поле "Тип файлов". Оказывается, этот GPSDump в курсе существования в природе файлов типа FSDB - сиречь, файлов соревнований программы FS. Ну, не чудо ли это?!!!
Быстренько воспользуемся этим чудом. Ищем и выбираем наш файл, созданный в Шаге 5. Я не забыл сказать, что кнопку "Открыть" нажать таки придётся?
Нажали? Тогда, окошко выбора файла исчезло, уступив место этой красоте:
Все наши участники - как на ладони. Со своими COMPID и CIVLID.
Остаётся сделать маленький штришок. Особой нужды в этом "штришке" для проведения соревнований нет, но... но потом вы можете горько сожалеть, что не сделали этого заранее.
Итак, что же нам даст активация (установка "птички") пункта "Add IGC file to comp. output" из меню "File"?
А даст оно нам... ни много ни мало, а самый что ни на есть настоящий ИГЦ файл с треком. В дополнение к КМЛ файлу, который и так будет создан и которым будет пользоваться программа FSComp.
Предвижу вопрос: а на хре... а зачем? Ответ: КМЛ файл содержит в себе, окромя самого трека, ещё какую-то фигню. Вдаваться в детали не буду - откройте КМЛ файл и посмотрите сами.
Будем считать, что убедил.
"Птичка" напротив этого пункта - поставлена!

Шаг 6.
Загрузка контрольных точек.
Заходим в "File" там выбираем "Open wpts." ищем файл с нужными точками.
Открываем. Получаем такой вот список.
Затем, полезно тыкнуть мышкой на любой из поворотников в списке, после чего нажать комбинацию клавиш "Ctrl+A" - выделить все точки.
Теперь в меню "Wpts" выбираем пункт "по вкусу".
Замечу, что в данный момент нас должны интересовать пункты, названия которых начинаются с "Send to" - мы же собираемся записать точки в прибор GPS, а не наоборот.
Также замечу, что для некоторых приборов наблюдается некое разнообразие.
Ну, например, для прибора Brauniger IQ Compeo+ можно высылать точки, названия которых следует взять из поля "ID" или... если угодно - из поля "Name". А можно - и то, и другое.
В чём разница? А разница в том, что поле "ID" не может содержать более 6 символов, а поле "Name" - может. Обратите внимание на список точек и текст в колонках "ID" и "Name" (на предыдущей картинке).
Осталось ответить на последний вопрос: в прибор какого участника будут заливаться точки?
Вариантов, как всегда, - куча. Можно выбрать пилота из списка - по имени/фамилии. Можно - по коду COMPID. А можно - и по CIVLID.
Выбрали? Жмём "ОК" и дожидаемся окончания загрузки точек в прибор.
После чего, получаем прибор, готовый к competition.
Кроме тех точек, что были открыты из файла, в прибор были записаны ещё две точки: COMPID и CIVLID. В них хранится информация о регистрационном номере пилота в списке участников соревнований, а также - о его регистрационном номере в списке ФАИ.
"Трогать" эти точки считается большим грехом.
Да! Маленькое примечание: если поле CIVLID окажется пустым, то точка CIVLID создана не будет. В этом нет большой беды. Проблем с идентификацией не возникнет, если в прибор записана только точка COMPID.